Remove this ad

Lead

Aug 17 11 5:39 AM

Tags : :

Hi everyone

I followed the installation instructions for the 4.0 version but i have a problem, the page stays blank, im not realy sure where the problem is but pls have a look by yourself:
pool.tenobis.com

BTW The new 4.0 Version of the Simplecoin Code looks just awesome at least on the simplecoin.us site ;)

Regards

Tenobis

Quote    Reply   
Remove this ad
Remove this ad

#1 [url]

Aug 17 11 2:22 PM

Sounds like a php error, check your apache logs......

Unfortunately, the theme of simplecoin.us is not part of the install. You would need to apply the theme from the link in the footer yourself.

Quote    Reply   

#2 [url]

Aug 18 11 8:20 AM

Thanks for your fast answer!
Yes i figured that with the Template, but my main problem still is the blank page, i checked my apache logs but i cant find any error shown there that would be related to it. All my other php sites works with the actual configuration, so it has to be something wrong with the code.

Tenobis ;)

Quote    Reply   

#3 [url]

Aug 18 11 9:07 AM

Surely there has to be some error, I see a 500 error when going to your page.

It's possible that it's related to a lack of data. Since I test on systems with existing data, it could just be that a null value isn't being tested for.

Quote    Reply   

#4 [url]

Aug 18 11 12:47 PM

I rechecked the requiredFunctions.php now twice all values are set correctly, aswell in the cronjobs the paths are set correctly aswell bitcoind, pushpoold, blkmond and memcached are up and running. when you go to http://mine.tenobis.com there you can see the xenland frontend working, right the pushpoold isnt set to the pool.tenobis.com yet but that shouldnt mather, since i tried the pushpool for a short period to run with the setting in the json file for pool.tenobis.com and got the same result. I wonder wich additionional libfile i possibly missing..

Like i said i started pushpoold blkmond and memcached with the settings for pool.tenobis.com but i got the same blank page result in firefox and a 500 error in google chrome

Quote    Reply   

#6 [url]

Aug 18 11 7:07 PM


I have the same issue.
Error message im getting is

Thu Aug 18 19:18:48 2011] [error] [client 203.37.10.154] PHP Fatal error: Uncaught BitcoinClientException: [0]: Didn't receive 200 OK from remote server. (HTTP/1.0 303 See Other)\n\n thrown in on line 0

Im going to try a different RPC port

Quote    Reply   

#7 [url]

Aug 18 11 9:22 PM

izotope, that is definitely the btc client not responding. I have my code tuned to Joel Katz patches for .24.

If you're going to run a pool, you'll need that patched btc client anyways.

Quote    Reply   

#8 [url]

Aug 18 11 9:33 PM

ok im running .24 stock. Would this be the issue?

Ill try Joel Katz btc client

this pool is for me and a few mates, not a public pool; im having alot of fun learning as i go though : )

thing is i was running v3.0 fine with no issues.

Im still getting a 500 message; i dont think the above message is causing the 500?

Quote    Reply   
Remove this ad

#9 [url]

Aug 18 11 9:54 PM

It likely is. The btcclient creates a memcache entry called from stats in requiredFunctions.

I'd wrap it in a try/catch, but I'd rather that stat fail as it's crucial to the site.

Perhaps I'll create an all-encompassing error catch all that is a little more friendly. Say in v5.

Which reminds me.... v4.1 is coming soon.

Quote    Reply   

#10 [url]

Aug 20 11 5:04 AM

I had the same problem ,
till i installed php5-memcached in ubuntu, and made the file speed
(

/api/pool/speed ) manually .

You need these 2 . A big headache ,
i have another problems now ,
like
PHP Warning: Invalid argument supplied for foreach()
in /var/www/includes/stats.php on line 89


and

PHP Warning: Invalid argument supplied for foreach()
in /var/www/stats.php on line 75

and

PHP Fatal error: Call to a member function fetch() on
a non-object in /var/www/includes/stats.php on line 42

I asked on other forums and some one replied to me that this query is not returning a value, so it gives an error.

$sql = "SELECT count(id) FROM shares WHERE id > $lastwinningshare AND our_result='N'";
and he said that most likely it will go away as soon as it returns something.

What do you think ? ( i am not able to start a new topic ... )

Quote    Reply   

#12 [url]

Aug 20 11 11:58 AM

Thanks,
what can i currently do ?
you can see me pool here ,
http://78.47.162.164/

forget the pushpool problem for currentbeing it needs restart ...

try registering and logging in and see the problem, the account logs in , but it does not show any logged in account , it says that it logged in successfully, but it doesn't stay like that after the redirection page ... ... what is it ?
What is the code for the stats.php in simplecoin.us ? your site ...

when will you release 4.1 ... please help . i really need to run it

Quote    Reply   

#15 [url]

Aug 21 11 6:15 PM

Hey Mate.

I have installed both joelkatz bitcoin and bitcoin-0.3.23

First am i correct in understanding u can't "make install" bitcoin?

i can run ./bitcoind from bin/32/ with the command ./bitcoind
I also can get information from ./bitcoind getinfo and all the daemon commands.

I then setup Pushpool and it initialised like normal.

However i now still have the issue of recieving a HTTP 500 error message.

Any ideas?

I repeat that V3.0 worked fine even though i was running 0.3.24 just some stats were not funcitoning correctly

Quote    Reply   
Remove this ad
Add Reply

Quick Reply

bbcode help